Emulation on Ubuntu

From Emulation General
Jump to: navigation, search

THE GNU/LINUX GUIDE OF EMULATION: *buntu Edition[edit]

Info for newfriends[edit]

A big difference between Windows and GNU/Linux is that when you want to install a program on Linux you don't have to go to the site, download an installer and install it (except in some specific cases).

There's something called repositories, which are like "app stores". You use a package manager to search for programs in the repositories, install them, update them and uninstall them.

Your Linux distribution comes with their official repositories already configured so you can get programs for there, but they don't always have every good emulator, and most of the time if they have it it's an old version. So what we are going to do is add more repositories that have up-to-date emulators. Once these repositories are added you will be able to install the emulators like with any other program and update them with the rest of your programs.

All this is cool, but there will be some emulators that you won't find on repositories, so you'll have to use different methods to get them, but don't worry, I'll explain it later.

IMPORTANT![edit]

This guide is focused on *buntu distros like Ubuntu, Xubuntu, Kubuntu, Lubuntu, and other Ubuntu derivatives such as Linux Mint. Repositories shown here WILL NOT work on other distros (Debian, Arch, Fedora etc), but you can find the same emulators for your distro somewhere else, either in their own repos (either official or unofficial) or by compiling them.

How to add the repositories[edit]

To add this repos you will have to run the next command on a terminal:

sudo add-apt-repository ppa:user/ppa-name

...where the ppa:user/ppa-name are the ones you'll find in the table for the repository you want to add. After you add all the repos you want you'll have to run the next command to update the packages database:

sudo apt-get update

Once that's done you will have all the packages from those repos available to install.

How to install, update and uninstall emulators after the repos are added[edit]

For this task I recommend you to install Synaptic. That program will be a lot of help. Once you have it installed you can choose to organize packages by source and see all the repos you have available. See what emulators each of the repos you added has and install the emulators you want.

Repositories List[edit]

The "Type" column describes how often the emulators are updated on these repositories. Testing repositories usually get updates quite often (some have daily updates) while Stable repositories usually get updates after a few months gap.

Emulators it has ppa:user/ppa-name Type Latest Emulator Version Supported Ubuntu Versions ARM(*7)
RetroArch ppa:libretro/testing Testing 1.3.4 14.04,15.04,15.10,16.04(*1)
ppa:libretro/stable Stable 1.3.4 14.04,15.04,15.10,16.04(*1)
VBA-M ppa:sergio-br2/vbam-trunk Stable 1.8.0.1508-r1343~12 14.04,15.04,15.10
PlayDeb(*3) Stable 1.8.0.1498-1~getdeb2~wily 16.04
PCSX2 ppa:gregory-hainaut/pcsx2.official.ppa Testing 1.4.0 14.04,15.04,15.10,16.04
MAME ppa:c.falco/mame Stable 0.164 14.04,15.04
ppa:c.falco/alpha(*5) Testing 0.174 15.10,16.04
Dolphin ppa:dolphin-emu/ppa
ppa:dolphin-emu/gcc-for-dolphin
Testing 5.0+git+r128 14.04(*2),15.04,15.10,16.04,16.10 ✓(arm64)
PCSX-Reloaded ppa:rebuntu16/pcsx-reloaded-svn+unofficial Stable/Testing 1.9.94+svn97809-1 14.04,15.04,15.10
PPSSPP ppa:ppsspp/testing Testing 1.2.2-r149 14.04,15.04,15.10,16.04
ppa:ppsspp/stable Stable 1.2.2-r134 14.04,15.04,15.10,16.04
Mednafen PlayDeb(*3) Stable 0.9.38.7-1~getdeb1 14.04,15.04,15.10(*6)
ScummVM PlayDeb(*3) Stable 1.8.0-1~getdeb1 14.04,15.10,16.04
DeSmuME ppa:random-stuff/ppa Stable 0.9.11+r1~4 12.04,14.04,15.04,15.10,16.04
Mupen64Plus Testing 2.5-7+r630~7 14.04,15.04,15.10,16.04
PokeMini Stable 0.60 14.04,15.04,15.10,16.04
Gambatte Stable 0.5.0 r577 (git) 12.04,14.04,15.04,15.10,16.04
Reicast Testing r7-rc (git) 14.04,15.04,15.10
Supermodel Stable 0.3a~WIP (svn) 12.04,14.04,15.04,15.10,16.04
mGBA Testing 0.3.0~WIP (git) 14.04,15.04,15.10,16.04
Snes9x Stable 1.53+git-r281~2 14.04,15.04,15.10,16.04
ScummVM, FCEUX, higan, ZSNES,
old versions of other emulators
Official Ubuntu repos (*4) Varies Varies Varies

*1:Core availability may vary between Ubuntu versions.

*2:Requires the newer version of libstdc++6 and related packages, which ppa:dolphin-emu/gcc-for-dolphin has.

*3:PlayDeb is not a PPA and must use different commands to add their repository. See the how to install section for more information.

*4:Only updated once per Ubuntu version.

*5:Some MAME builds may also appear in ppa:c.falco/trashbin, but it is unused as of May 17, 2016.

*6:Ubuntu 16.04 has Mednafen 0.9.38.7 in the official Ubuntu repository.

*7:Repository with ARM support might work with HP Hardfloat, odroid, Raspberry Pi 2, etc.

You can find more repositories by searching "emulatoryouwant launchpad ppa" without the quotes. Check that they have packages for your Ubuntu version (usually by its name, e.g. Trusty is 14.04, Vivid is 15.04, Wily is 15.10, Xenial is 16.04), as some PPAs can be abandoned.